Skocz do zawartości
Zaloguj się, aby obserwować  
mk91

Streamowanie a lagi.

Polecane posty

Witam,

 

mam takie pytanie. Znajomy ma upload 16 mb a mimo to na bitrate 3000 gdy oglądam jego stream to co kilka sekund zacina się, po czym dalej live leci. Ogólnie nie da się oglądać na takich ustawieniach. Dopiero bitrate w okolicach 1500 załatwia sprawę. Teraz pytanie jak można to poprawić/zmienić bo gdzieś błądzi w ustawieniach raczej z takim netem na 100%, co może być nie tak?

 

Jego komputer:

Procesor: i5-4460/3.2GHz

RAM: DDR3 8GB 1600MHz CL9 Crucial Ballistix

Płyta główna: AsRock B85M Pro3/Intel B85, LGA 1150

Karta graficzna: GeForce GTX 970 JetStream 4GB DDR5 256bit

 

Internet:

 

http://www.speedtest.pl/test/116744897

 

Nie wiem co jeszcze może być przydatne. Proszę o pomoc.

 

Pozdrawiam.

Edytowano przez Fuzzik
Estetyka repaired.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Podeślij screeny ustawień z OBS lub innego programu, którego znajomy używa. Temat przenoszę do tematów technicznych.

http://imgur.com/FyBebqO

 

http://imgur.com/a/eDX9i

 

Potrzebne są jakieś jeszcze?

 

EDIT.

 

@Fuzzik

 

Na innych streamach, gdzie bitrate jest 3500 stream chodził mi bez ścinki ciągle żadnej a u niego na 2000 bitracie już są problemy a co mówić na 3500... Też tak myślałem na początku dlatego testowałem inne streamy i tych problemów nie było.

Edytowano przez mk91

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Jeszcze daj zakładkę zaawansowane. Powiedz koledze niech ustawi kodek na NVENC, aby wykorzystywał GPU do kodowania wideo, i niech wjedzie z bitrate na 3000 minimum. Może będzie lepiej. W razie czego może ustawić 2 sekundy opóźnienia.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@SoldierPL

 

Dzięki za pomoc. Zobaczę, czy to coś pomoże. Zakładka "zaawansowane" jest w tych moich screenach, które zrzuciłem. Poszperaj tam, znajdziesz na pewno bo ja widzę.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A, faktycznie :D Nie ogarnąłem, że w dół da się zjechać. Priorytet procesu zalecam wysoki i czas buforowania sceny 700. Jak nic z tego nie pomoże, to warto wykonać ten test: http://testmy.net/upload i zobaczyć czy nie dropi prędkość (testy wykonywane przez strony używające flasha zwyczajnie nie podają prawdziwego wyniku). Koledze nie uciekają klatki?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Zmienił to ale dalej się zacinało. Wygląda to tak, że widzę na streamie, że zaczyna się video powoli przycinać, tracić prędkość aż w końcu się zawiesza, stoi w miejscu po czym po chwili odtwarza dalej normalnie. Później znowu z 15-20 sekund jest dobrze i ponownie to samo, zaczyna powoli zwalniać aż w końcu zwiecha. Wygląda to dla mnie jakby z netem było coś na logikę biorąc.

 

Screen z testu:

 

http://imgur.com/nKC8e79

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Zaczynimy od tego, że bez partnerstwa stream leci przez jakieś serwery w piwnicach twitcha i sam serwis zaleca streamowanie w max 2,5k bitrate. 3,5k to raczej opcja dla osób z partnerstwem. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@SoldierPL

 

Napisał mi, że on ma w ustawieniach coś takiego jak "% zgubionych klatek" to widnieje u niego 0%, to chyba o to Ci chodziło?

 

@isdn

 

Poważnie? Przez coś takiego może mu się stream zawieszać? O tym to akurat nie pomyślałem, ale coś w tym może być jeśli przy partnerstwie ma się lepsze warunki itp. Brzmi logicznie. Jak nie wiadomo o co chodzi to chodzi o... Kappa

Edytowano przez mk91

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.
Zaloguj się, aby obserwować  

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

Legenda grup:

  • Administrator IT
  • Administrator
  • Ekipa Ja, Rock!
  • Streamer
  • Moderator
  • Moderator Działu
  • Moderator Techniczny
  • Technik Sprzętowiec
  • Grafik
×