Skocz do zawartości
Zaloguj się, aby obserwować  
Ozzy123

Problem ze streamowaniem - ciągłe buforowanie, spadki jakości.

Polecane posty

Byłem pewien, że ktoś już miał taki problem więc poszukałem trochę na internecie ale nie znalazłem niczego co by rozwiązało mój problem a więc - mam ochotę sobie postreamować dla znajomych i nie tylko w sumie już od dłuższego czasu i od dłuższego czasu ze streamowaniem mam problemy. Problemy pojawiają się nawet gry streamuje gry takie jak tibia, a kiedy chcę postreamować lola i csa to już w ogóle nie da rady. 

 

specyfikacja mojej maszyny : 

Grafika : Gigabyte Radeon R9 280 Oc 3GB (384Bit) 

Procek : Intel i5 4590

Ram : ddr3 8gb 800mhz nie wiem jakiej firmy :P

OS : win7 64bit HP

 

Internet : 

Download : 50mb/s

upload : ~3mb/s

 

ustawienia obs :

 824e48de6f.png5e5e7d8944.png

 

 

A więc problem jest taki : kiedy moi znajomi wchodzą na stream to ciągle się on buforuje, na 5 sekund oglądania jest 30 buforu, a kiedy już stream jakoś ruszy to problem jest następujący : kiedy moja postać w grze np w fallout 4 stoi w miejscu to wszystko jest ok ale kiedy zaczynam nią biegać to obraz strasznie się pixelizuje, rozmywa. Nie mam już pomysłu co zrobić, proszę, pomocy. 

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Pokaż wszystkie ustawienia OBS. Sprawdź dokładną prędkość neta narzędziem, które nie wykorzystuje flasha: http://testmy.net/upload - kilkasz "Test Upload Speed" i podaj dokładny wynik. Zaznacz jeszcze opcję "Użyj własnego rozmiaru bufora" w zakładce "Kodowanie".

A właśnie, na jaki serwis streamujesz (Twitch, Hitbox etc.)? 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

QUtKPYbud.png

test robiłem chwile po włączeniu komputera z programami w tle takimi jakie są podczas streamowania tj opera, skype, teamspeak,steam

 

wszystkie ustawienia : 

 

http://puu.sh/lS4VR/bfbe21c847.png

http://puu.sh/lS4Wp/8a51c66fbe.png zazwyczaj max przepływność jest 2048, zmieniłem na 1500 dla testów co nie przyniosło efektów xd 

http://puu.sh/lS4WW/ee8a520f66.png

http://puu.sh/lS4Y3/6d4449b16b.png

http://puu.sh/lS4YD/e59c3cfb1a.png

http://puu.sh/lS4Zk/c145d624b7.png

http://puu.sh/lS4ZU/947222c5a3.png

 

streamuje na twitchu

Edytowano przez Ozzy123

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Przestaw serwer na Frankfurt (chyba że mieszkasz w Holandii). I zaznacz, to o czym mówiłem wyżej :D Co do pikseli, to dopóki będziesz streamować tylko do 720p, dopóty będą piksele. Z kolei 1080p uniemożliwi oglądanie streama osobom ze słabszym netem - tu musisz wybrać co wolisz. Mógłbym ci zaproponować przeniesienie obciążenia na enkoder VCE, co sprawiłoby, że każda gra podczas streamu zachowywałaby się tak samo jak bez live, jednak procesor powinien wyrabiać, a VCE potrzebuje większy przepust, aby uzyskać tą samą jakość co x264, a do tego ma problemy z utrzymaniem bitrate na żądanym poziomie przy przeskakiwaniu między grami, co oznacza, że musisz często restartować stream.

 

Ustaw jeszcze bitrate na 2500 i rozmiar bufora także na 2500. Wtedy sprawdź.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

http://scr.hu/1qi3/7zmgi screen od kolegi po zmienieniu : 

 

-na frankfurt

-ustawiłem w obrazie żeby nie zmniejszało rozdzielczości (1080p)

-ustawiłem użyj własnego rozmiaru bufora czy jakoś tak

 

po chwili zmieniłem bitrate na 2048, koledze załadował się stream na 5 sekund i potem znowu bufor wieczny 

 

edit : 

 

ściągnąłem inną wersję obsa tą z obsługą VCE, odpaliłem streama z takimi samymi ustawieniami jak wcześniej

 

perspektywa kolegi : http://scr.hu/1qi3/cjqkp (wieczny bufor) 

Edytowano przez Ozzy123

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Czyli wychodzi na to, że musi ci dropić upload. Jedyne co możesz zrobić to wykonać telefon do dostawcy neta. A jeszcze zapytam kontrolnie: w jaki sposób masz dostarczany internet? Jest to gniazdko telefoniczne i wszystko idzie kablem do routera, a potem nadal kablem do kompa, a może przez WiFi? Może to jest internet bezprzewodowy?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Gniazdko telefoniczne i wszystko idzie do routera, potem do kompa. Sprawdzałem na tej stronce bez flasha kilkukrotnie i był upload od 3mb/s do 4mb/s nie spadało poniżej raczej. Dodatkowo przed chwilą z 30 min streamowałem z tibii i mój kolega mówił, że wszystko było git - 0 buforu. Czy CS:GO wymaga więcej uploadu do streamowania niż Tibia? Nie znam się na tym ale wydaje mi się to trochę bez sensu :D

 

 

EDIT : 
 

Wymieniłem kolegę na takiego z trochę lepszym internetem i u niego wszystko bangla! Tylko, że jak stoję w miejscu (np w csie) to jakość jest ideolo bardzo dobra a kiedy zaczynam biegać to ekran "śnieży" i widać ruszające się pixele, jak to naprawić? 

Edytowano przez Ozzy123

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Na piksele wpływają dwa główne czynniki: rozdzielczość i bitrate. Wyższy bitrate = lepsza jakość. Popróbuj z wyższymi wartościami, ale staraj się zachować około pół mega na grę, aby ping ci nie skakał.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Im bardziej wymagająca gra tym większego bitrate'u potrzeba. W Tibii masz mało do renderowania, więc nie ma problemów, natomiast w CS ciągle coś się dzieje i potrzeba więcej.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Chcesz dodać odpowiedź ? Zaloguj się lub zarejestruj nowe konto.

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to bardzo łatwy proces!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się

Zaloguj się, aby obserwować  

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

Legenda grup:

  • Administrator IT
  • Administrator
  • Ekipa Ja, Rock!
  • Streamer
  • Moderator
  • Moderator Działu
  • Moderator Techniczny
  • Technik Sprzętowiec
  • Grafik
×